» Supported phones » BlackBerry » 7290 (4.1)

BlackBerry 7290 (4.1)

Status

Phone not tested, but Locify probably won't run.

This phone won't probably run Locify. However you can still try it. If you succeed, let us know, please.

Download Locify for this phone

Read more about Locify on this device.

If your experience with running Locify is other than the one presented here, fill in please our contact form.

Set as my phone

Notes

We are currently working on resolving issues with BlackBerry phones. Stay tuned for updates.

User comments

No comments so far.

Add comment

Only registered users can add comments.